Windstream compatible modem for a non-bonded connection

When my Windstream modem was repeatedly power cycling when trying to connect, tech support said this was the modem letting me know it was damaged and needed to be replaced. They offered to rent me a modem for $10/month but oh my god no, why would I do that? This one lasted me over 10 years.

To their credit, they were super helpful and said I could buy one and recommended the following:

  • a Netgear or Linksys modem
  • with an ADSL chipset
  • and a VDSL2 port

One thing to note is that I don’t have a bonded connection so if you’re reading this because your modem died, you’ll need to call them and find out what you need. If you don’t know what a bonded connection is, just ask them if you have one, if they say yes, don’t buy the modems below! ☺️

So ok, should be easy, right? Well, not quite. There’s not a lot around here so I had to drive about 45 minutes to the nearest Staples (again, not a lot of choice of stores and the local Walmart doesn’t stock ADSL modems — not sure if all Walmarts don’t stock them or just the one around here)  and ended up buying the only thing they had which fit the specs, the NETGEAR Nighthawk WiFi VDSL/ADSL Modem Router (D7000) .

This, although expensive, works beautifully and is speedier than the previous Windstream modem / Netgear router. It’s expensive though! I think this Netgear VDSL/ADSL modem would work too.

One frustrating thing in this was that no one really knew anything about modems, so weren’t much help finding what I needed. The local computer shop guy nearly refused to believe I even knew what the specs were — I guess people come in all the time having made up modem specs just for the sheer hell of it? or maybe it was something else, hmmm — so there was a bit more to it. Kudos to Walmart guy for knowing straight away they didn’t have one and offering what he knew.

Back to the modem/router I got: setting it up was straightforward although I’m super impatient and it took a couple of minutes for the DSL connection light to turn on, so don’t panic. I had forgotten to write down my old modem settings so used the setup assistant. It took a few goes to get it right — I think there was an issue with pasting my password into the form as it only worked when I typed it in. Not sure if that was user error or not but if you get to that point, the modem itself is working, it’s probably the authentication that’s an issue so look at it from that perspective and check your details.

What do you think?

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s